BEA WebLogic Server 10.0 läuft nicht mit Java 6

Obwohl wir seit Jahren erfolgreich JBoss einsetzen muss ich für einen neuen Kunden WebLogic von BEA testen. Der Kunde nutzt die aktuelle Version 10.0. Vorsicht: WebLogic 10.0 (veröffentlicht am 10.04.07) läuft nicht mit Java 6 (veröffentlicht am 11.12.06). Hm, das alleine ist zumindest merkwürdig. Neue Java Versionen sind in der Regel abwärtskompatibel. So läuft z.B. JBoss-4.0.2, der vor Jahren veröffentlicht wurde, problemlos mit Java 6. Richtig ärgerlich ist aber, dass in der WebLogic Dokumentation nicht darauf hingewiesen wird. Es gibt viele Megabyte Dokumentation zur Version 10.0, z.B. Installation Prerequisites mit System Requirements oder Supported Configurations for BEA WebLogic Platform 10.0 mit Hinweisen zu Betriebssystemen, Web Servern, Datenbanken und sogar Spring Versionen. Es gibt aber keine Hinweise welche JDK Versionen unterstützt werden. Nur indirekt wird darauf hingewiesen. Die WebLogic Server 10.3 Tech Preview unterstützt erstmals Java 6:

This Technology Preview includes select new features, standards updates and performance improvements. Version 10.3 TP remains fully Java EE 5 compatible and adds new support for Java SE 6.

Vielleicht ist es BEA etwas peinlich, dass ihr 10000$-Server sich nicht mir Java 6 verträgt. Ich habe einen ganzen Tag damit verschwendet die 10.0 mit Java 6 zu testen bis ich endlich den Hinweis gefunden habe.

  1. No trackbacks yet.

Schreibe einen Kommentar

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s

%d Bloggern gefällt das: